Page 1 of 1

[Android]TWebBrowser

PostPosted: Wed May 03, 2017 12:57 am
by Lena
Hi.
I click the button to open the form with TWebBrowser:
Code: Select all
FormWEB = new TFormWEB(this);                       
FormWEB->WebBrowser1->Navigate(L"http://bcbj.org/");
FormWEB->Show();

I see the word "Download" in the label, and when the page is loaded the label becomes empty. It's okay.
If already in the open page in the TWebBrowser window there is a hyperlink and click on it, then the word "Download" is not already seen in the label.
How to click on the link in the TWebBrowser, to show in the label the "Download" word?
Code: Select all
void __fastcall TFormWEB::WebBrowser1DidFinishLoad(TObject *ASender)
{
 Label1->Text = L"";
}
//---------------------------------------------------------------------------
void __fastcall TFormWEB::FormShow(TObject *Sender)
{
 Label1->Text = L"Download...";
}
//---------------------------------------------------------------------------
void __fastcall TFormWEB::WebBrowser1DidStartLoad(TObject *ASender)
{
 Label1->Text = L"Download...";
}

Re: [Android]TWebBrowser

PostPosted: Wed May 03, 2017 1:46 pm
by rlebeau
Lena wrote:If already in the open page in the TWebBrowser window there is a hyperlink and click on it, then the word "Download" is not already seen in the label.


Are you saying that clicking on a hyperlink is NOT triggering the OnDidStartLoad event? It should be. If it is not, file a bug report with Embarcadero.

Re: [Android]TWebBrowser

PostPosted: Wed May 03, 2017 11:27 pm
by Lena
a bug report with Embarcadero


Thank You!
RSP-18035